
Rhythm Rascal Quick Start Guide 
Overview 
Rhythm Rascal is a virtual drum machine that can be programmed to play any style of 
music.  It allows you to create unlimited patterns within a song, and each pattern may 
have its own meter and tempo defined.  Killer drum samples are included, and you can 
even import your own sound samples from wave files.  The samples may be further 
configured by adjusting their volume and pan within Rhythm Rascal.  The song can be 
mixed down to a standard WAV file for playback in an audio player, or for import into a 
multi-track recording software package. 
 

 



Concepts 
The following are key concepts you should be familiar with before starting with Rhythm 
Rascal. 
 
Drum Kit – A virtual “drum kit” representing a collection of sound sample files. 
Pad – A “drum pad” representing a piece (sound sample) of the drum kit, such as a bass 
drum or crash cymbal. 
Pattern – A sequence of sounds that may be repeated within the song.  Patterns are the 
building blocks of songs.  A pattern is usually a musical “measure” or “bar”, but in some 
cases a single pattern may represent multiple bars. 
Song – A sequence of patterns, in a specified order, to build a complete song. 
Step – A position in time within the pattern.  There are (Beats * Notes per beat) steps in a 
pattern.  For example if a pattern has 4 beats, with 3 notes per beat (triplets), then there 
are 12 steps in the pattern.  A step is the smallest unit of time for placing drum hits. 
Hit – A drum hit.  This means a sound is being played at a specified step within the 
pattern. 
Project – A song’s data file, including all patterns and the configuration of the pad 
samples (but not the sample wav files themselves). 
 

Basics 
The basic procedure for creating a song is as follows.   

1. First a “drum kit” must be created.  This involves selecting wave files from your 
hard driver to be used in the song.  By default Rhythm Rascal loads your “default 
kit”, so as long as it meets your needs, no action needs to be taken.   

2. The next step is to create patterns.  Patterns are used to build the song.  Patterns 
can be created in any order, and arranged in the song as desired later.  Note that 
patterns can be repeated, and reused at different points in the song, so you never 
need to write the same pattern twice. 

3. Then patterns can be arranged to form the song. 
4. Once you have the song arranged, the entire song is mixed down to a wave file, or 

exported to a MIDI file. 
 

Loading and Saving Song Project Files 
 
Use File->Open to open an existing song project from a data file.  Rhythm Rascal song 
files usually end with the “.rrp” file extension.  This stands for Rhythm Rascal Project. 
 
Use File->Save or File->Save As… to save the song project as a data file for later use. 
 
Any time you change a song project, the title bar of the window will show an asterisk (*) 
after the filename to indicate that it needs to be saved.   
 



 
 
If you try to close the application or open another song, you will be prompted to save the 
current song first. 
 
The first time Rhythm Rascal is run, it registers the file extension “.rrp” for Rhythm 
Rascal Project files.  After the first time it is run, a song (or “project”) file can be opened 
by simply double-clicking it in Windows. 
 
You can also open a project file by dragging it from the Windows explorer onto the 
Rhythm Rascal application. 
 

Playback control 
Playback is controlled by the Playback Control Panel, in the toolbar. 
 

 
 
An explanation of each item on this toolbar is below: 
 

  
The playback mode is determined by this drop-down list.  Available modes are Pattern 
and Song. 
 

  
The song tempo controls the tempo in Beats per Minute (BPM).  This tempo will be used 
by default. However, any patterns having the Song BPM unchecked will use their own 
tempo instead. 
 

  
The Play button starts playback of the current Pattern or Song, depending on the current 
mode specified by the drop-down list.  If in Pattern mode, the current pattern will be 
played.  If in Song mode, the song will be played starting at the current song part. 
 
NOTE: You can also start playback by selecting the play button from the right-click 
menu on the pattern or song part list.  You can start playback by double-clicking the row 
selector, too (this is optional). 
 

  
The Stop button stops playback of the currently playing song or pattern. 
 



 
The Loop button toggles between looping and non-looping playback for patterns and 
song. 
 

 
The Record button toggles record mode.  With this turned on, any pads played during 
pattern playback will be added to the pattern at the current step.  This is for a real-time 
recording.  

 
The Metronome button toggles metronome mode.  With this turned on, a click will be 
played on each beat.  The click is slightly accented on the first beat.  This is particularly 
useful for real-time recording. 
 
During playback, the current pattern name and currently playing beat will be displayed in 
the playback control panel.  For example, in this screenshot, beat 1 is being played within 
the “roll” pattern.  
 

 
 
 

Pad Configuration (“the drum kit”) 
 



 
 
Rhythm Rascal uses a virtual “drum kit”, which is actually a collection of sample wave 
files.  These can be any wave files on your hard drive.  A few are included in the 
installation, but you can always add more.  Sample wave files are freely available on the 
Internet.  NOTE: A web search for “sample wave files” usually turns up a nice selection 
to choose from. 
 
You’ll probably want samples for each type of drum within a typical drum kit (snare, 
bass, high hat, ride, crashes, and one or more toms).  You can select any wave file (must 
have “.wav” extension) on your hard drive.  NOTE: All samples used within a song must 
have the same sampling rate.  If you try to add a new sample pad that has a different 
sampling rate, an error message will be displayed informing you that it cannot be added. 
 
New “pads” (samples) can be created by clicking the “New Pad” icon in the editing 

toolbar , or by right-clicking anywhere on the Pad display background and choosing 
“New Pad”:  
 



Either of these methods will launch a browser window to open sample files to be used in 
the song.  
 
NOTE:  While in the open file dialog, hold the CONTROL key as you click to select 
more than one wave file. 
 
Further, pads can be added by simply dragging sample wav files onto the Rhythm Rascal 
application from Windows explorer. 
 
By default, the pad name will be set to the filename, but you can change the pad name as 
desired.  Change it to something easy to recognize, such as “bass” or “snare”.   
 
You can adjust the volume and pan of each sample.  Volume ranges from 0 (silence) to 
100 (full volume).  Pan ranges from -100 (left) to 100 (right).  To center the sound set the 
Pan to 0.  Further, the pads can be muted if you want to try a song without hearing the 
specified pad. 
 
Each pad can be assigned a color.  This color will be used to display hits for the pad 
within the pattern, to make it easier for you to distinguish each drum pad quickly.  The 
default is Red, but you can pick any color using the color picker in the Kit window. 
 
Each pad can be mapped to a MIDI note.  This only affects the MIDI export feature 
(under the Tools menu), and does not affect real-time playback or wav mixdown. 
  
These operations do not alter the original wave files.  Rhythm Rascal uses “non-
destructive” editing of the sample files.  This means that it will never modify any of your 
original samples.  Rhythm Rascal only uses this for determining how to mix each sample 
during playback and during final wave mixdown. 
 
Rhythm Rascal remembers your “default kit”, and can load it each time you create a new 
song.  If you make changes to your kit and decide you want to load it each time you 
create a song, use the “Save Kit As Default” option on the Tools menu. 
 

 
 



If you don’t want to load a default kit by default, you can change this behavior in the 
KitOptions configuration: 
 

 
 
To remove unwanted drum pads from the kit: 
Right-click one or more pads and click Delete, or press the Delete key to delete drum 
pads. 
 
NOTE: You can load the drum kit from another song by using the Tools->Load kit from 
another song menu item.  
 
NOTE: You can change the view style of the drum kit editor.  It can be viewed in Grid 
view or Card view.  To change the view style, right-click on the kit editor pane, and 
select or deselect “Card View”. 
 
Card view shows each pad as an expandable object: 
 



 
Drum Kit Card View 
 
Grid view displays the pads in a tabular format: 

 
Drum Kit Grid View 
 
Once you get all the samples you need for the song, you can proceed to building patterns.  
Of course you can always add more samples to the project after building patterns. 
 



Pattern Editing 

To begin editing a pattern, create a new one with the New Pattern button   on the 
editing toolbar.  Rhythm Rascal assigns a default name to each pattern (such as 
Pattern005, and so on).  You can specify a more descriptive name if desired, such as 
“Intro” or “Verse Fill 1”. This will make it easier when arranging the song later. 
 
NOTE: You can load common patterns from templates that come with Rhythm Rascal, 
using the Edit->Pattern->New Pattern from template menu item.  You can also simply 
right-click in the pattern list and choose this option.  Once you’ve loaded the template 
pattern, you can edit it as needed in this song. 
 
NOTE: You can insert existing patterns from other songs you’ve written, using the Tools-
>Load Patterns from another song menu item.  
 
You can change the tempo, number of beats, beat type, and notes per beat for each 
pattern. 

o Song BPM – Click this box to use the current song tempo for this pattern. 
o Alt. Tempo – If Song BPM is unchecked, the pattern will use this alternate tempo.  

Enter the tempo of the pattern, in Beats per Minute (BPM). 
o Beats – The number of whole beats in the pattern.  This is the number that is used 

with Tempo to determine the playback speed.  This is usually the top number in 
the time signature. 

o Beat Type – The type of note that gets a beat.  This is usually the bottom number 
of a time signature.  Most songs use 4 (Quarter note). 

o Steps per beat – The number of divisions within each beat.  For example, to do 
“triplets”, set this to 3.  For quintuplets, set this to 5, and so on. 

 
There are two modes of recording, design mode, and real-time mode.  You can use either 
or a combination of both methods to record your patterns.  Often you can get the beat 
roughed in using real-time recording, and then fill in the details, such as fast rolls, using 
design mode. 
 
Real-time Recording 

When the record button on the playback toolbar is turned on , any pad you play while 
the pattern is playing will be recorded into the pattern.  The easiest way to do this is to 
enable looping and record mode on the toolbar, then just start clicking the “play” buttons 
beside each pad in the grid.  You will see the LEDs light up as you play.  The metronome 
(turn it on in the toolbar as well) comes in handy for real-time recording, so you can hear 
the beats while recording. 
 
Design Mode Recording 
With a pattern selected, the grid of LED buttons will display the hits for the pattern.  
Each drum pad will have a row in the grid.  Create hits for each drum pad at the desired 
beat within the pattern by clicking the LEDs to turn them on or off. 
 



For example, if using 4 beats with 4 divisions (4/4 with sixteenth notes), there will be 16 
total steps in the pattern. 
 
Let’s examine an example pattern: 
 

 
 
This pattern is called “stomp short 2”.  It is a standard 4/4 time signature (4 beats, with 
Quarter note as the beat type).  The Notes per beat is 4, so each step is a sixteenth note.  
This song is set to use the song tempo, so it will assume whatever the song tempo is at the 
time of playback (currently 180). 
On beat 1, the “bassdrum” and two crash cymbals are hit.  Then the “hi hat” is hit on 
every other step, effectively playing eighth notes.  The “snare” is hit on counts 2 and 4, 
and the “bassdrum” is hit on the upbeat of beat 2, beat 3, and the upbeat of beat 4. 
 
Typically, you’ll design a handful of patterns, and then decide to a make a song.  
Although you can iteratively edit patterns and the song as needed…. 

You can create a copy of an existing pattern using the “Clone Pattern” button  on the 
editing toolbar (You can also simply Copy/Paste a pattern within the Pattern List).  
Everything for the pattern will be copied to the new pattern.  You’ll usually want to 
change the name of the new one to distinguish it from the old one. 



 
There are a few shortcut operations for common pattern editing tasks.  These can be 
accessed from the Edit menu, or by right-clicking the pattern properties area, or on the 
lower grid. 

 
 
Double steps per beat – This option attempts to double the “Steps per beat” of the 
pattern.  This is significant because it preserves the original beat sequence.  Normally, if 
you simply use the numeric field to set Notes per beat, the drum hits will stay in the same 
step numbers, but the beats will “move”.  Using this special operation, the hits are moved 
to the new steps relative to the new placement of the beats.  This is particularly useful if 
you’ve already written a pattern with eighth notes, and then realize you need more 
divisions to get sixteenth notes, etc. 
 
Clear pattern – This is a quick way to remove all hits for all drum pads for this pattern. 
 

 
 



Select even beats for this pad – This will place a drum hit on the first step of each beat, 
for example on beats 1, 2, 3, and 4.  This is particularly useful for hi hat or ride cymbal 
hits, which usually occur on every full beat.  This affects the currently selected drum pad. 
 
Select all hits for this pad – This will place a drum hit on every step for the currently 
selected drum pad.  This is useful for double-bass patterns and so forth. 
 
Deselect all hits for this pad – This is a quick way to remove all hits for the currently 
selected drum pad. 
 
Clear pattern – This is a quick way to remove all hits for all drum pads for this pattern. 
 
Funk it up! – This inserts random syncopation for the currently selected pad.  A few 
random hits will be placed to spice up the pattern. 
 
Removing unwanted patterns 
Right-click one or more patterns and click Delete, or press the Delete key to delete 
patterns. 
 
Note that the order of the patterns in the list is insignificant.  Ultimately the order of the 
song parts in the Song Sequence is how the song will be heard. 
 

Song Details 
Details about the song, including a description and default pattern information is in the 
Song Details window. 
 



 
  
The default values, Beats, Beat type, and Steps per beat, are only used when creating new 
patterns.  By default, new patterns are created with 4 beats, 4 Notes per beat (divisions), 
and Quarter note beat unit.  If you’re working on a song in 5/4 for example, you should 
change the Beats here in the song details to 5.  This automatically sets new patterns’ beats 
to 5.  This will save you a few clicks each time you create a new pattern. 
 
The Description is a free form text area you can use to make notes about the song.  
Rhythm Rascal does not use it internally, so you can type anything you want here. 
 

Song arrangement 
The Song Sequence pane is where you arrange the flow of the song.  Once you have 
some patterns defined you can start arranging them.  A song consists of “Song Parts” – 
each song part represents a pattern, with any number of repeats. 
 



 
 
The Part number displays the sequence number within the song.  This is not editable.  
Playback starts at part 0. 
 
The Pattern displays the name of the pattern to be played at that part of the song.  You 
can change the pattern to be played here by selecting from the drop down list. 
 
Set the # Times value on each part to control looping. The default value of 1 means the 
pattern will be played once at that point in the song. 
 
By default each time you create a pattern, it will be added to the end of the song 
sequence.  This behavior can be changed in the Options form by deselecting the 
“Automatically add new patterns to the end of the song” option. 
 
You can also add patterns to the song by dragging them from the Pattern List over to the 
Song Sequence window.  You can select one or more patterns in the list and drag them to 
the song sequence.  
 
You can also select a pattern (or multiple patterns), right-click and Copy them, then right-
click in the Song Sequence and choose Paste.   
 



IMPORTANT: If you drop (or paste) them on top of an existing song part, they will be 
inserted before that part.  Drop (or paste) them at the end of the song (below all the parts) 
to append them to the end of the song. 
 
You can also add new song parts by using the Edit menu, or by right clicking in the song 

sequence window, or by using the Insert Song Part  or Append Song Part  buttons 
on the Editing toolbar. 
 
Removing unwanted song parts 
Right-click one or more parts and click Delete, or press the Delete key to delete song 
parts. 
 

Wave Mixdown 
When you are finished with the song and are ready to build a wave file, use Tools-

>Mixdown to wave file  to render the song project to a single wave file.  You will be 
prompted to select an output file.  You can select an existing file to overwrite or enter a 
new file to create. 
 
After selecting a file, mixdown will begin.  The current progress, along with the file 
properties is shown in the Mixdown dialog form: 
 

 
 
None of these options can be changed.  Rhythm Rascal always outputs in stereo (if any of 
your samples are mono, they are still mixed in stereo during the mixdown).  The sample 
rate and sample bits are determined by samples. 
 
NOTE: The mixdown uses the Humanization features configured in the Options window.  
See that section below for more information. 
 



When mixdown is complete, the Open and Open folder buttons become enabled. 
 

 
 
Open launches the new wave file in your default player (usually Windows Media 
Player). 
Open Folder opens an explorer window with the new file selected.  This is handy if you 
will be copying the wave file to another application. 
Close closes the Mixdown form and returns you to the main window. 
 

Export to MIDI File 
When you are finished with the song and are ready to save a MIDI file, use Tools-

>Export to MIDI file  to save the song project as a 
MIDI file.  You will be prompted to select an output file.  You can select an existing file 
to overwrite or enter a new file to create. 
 
You can specify which type of MIDI file (format 0 or format 1) in the MIDI Options 
page. You should check the documentation of your midi applications to see which format 
is supported. 
 
Note that you must assign MIDI notes to each drum pad in your kit that you want to be 
saved to MIDI.  Any pads that are not assigned a note will be left out. 
 



Options 
Rhythm Rascal allows you to customize certain behaviors to suit your needs.  The 
Options window is available by using Tools->Options from the menu, or by clicking the 

Options button on the toolbar  
 
The first tab is for basic program settings. 
 

 
 
Show tips at startup controls whether quick tips are shown each time the application is 
launched. 
 
Enable advanced tooltip help controls whether all tooltips are shown, or only the ones 
related to the toolbar icons. 
 
Double-click to start playback 
With this option on, Rhythm Rascal begins playback of the pattern, pad, or song when 
you double-click on a pattern, pad, or song part.  Note:  you must double-click the row 
selector on the left of the pattern or song part to playback: 



 
 
Working folder is the folder where you want to keep Rhythm Rascal data files.  This is 
merely a suggestion, because you can always save your files to any folder you want.  This 
is also used to locate wav sample files. 
 
Temp folder is the folder Rhythm Rascal should use for temporary scratch space.  This is 
used during mixdown and during project import/export operations. 
 
The next tab is the Kit tab. 
 

 
 
Default pad volume is used each time you create a new drum pad. 
 
Master playback volume is used to control the overall volume during playback. This is 
useful if all your samples are either really quiet or really loud. 



 
The For new songs section specifies the action to take when creating new songs. 
 
The Additional WAV samples folders is a list of folders on your hard drive which 
should be searched for wav files.  Rhythm Rascal stores only the relative filename (not 
the full path) to each sample file.  This is done so that if you move your work to another 
computer or change folder names, you can simply add the correct folders here instead of 
having to change the filename in each drum pad. 
 
The next tab is Song. 
 

 
 
Automatically play songs when opened 
With this option on, Rhythm Rascal begins playback of the song immediately when you 
open the .rrp file. 
 
Automatically add new patterns to the end of the song 
With this option on, each pattern is appended to the end of the song for you.  This is 
merely a convenience since many times you create the patterns in the order you want 
them in the song. 
 
 
The next tab controls the Mixdown options. 



 
 
The Master mixdown volume is similar to the Master playback volume on the Kit tab.  
This controls how much gain is applied to all samples during the wav mixdown. 
 
The Humanization feature affects the mixdown only (not playback).  With this turned on, 
random velocity (volume) and timing offsets are used on each beat, to simulate a human 
drummer.  This helps your final recording feel more relaxed and less mechanical.   
 
Slide the Timing and Volume randomization controls left for less randomization (more 
mechanical) or right for more effect (more human).  You should experiment with these 
until you are happy with the overall feel of the wave mixdown.  Be careful as you adjust 
these far to the right as this can cause it to sound very sloppy! 
 
The Restore Defaults button resets the values back to the original settings, which is 
suitable for most users. 
 
 
The next tab controls the MIDI options. 



 
 
The MIDI Drum Channel specifies the channel you wan to use for MIDI file export.  
This is 10 for most systems. 
 
The MIDI File Format specifies the type of MIDI file to export.  You should check the 
documentation of your midi applications to see which format is supported. 
 
 
 
The last tab controls the appearance of the application. 



 
 
Rhythm Rascal allows you to move windows and toolbars around.  It remembers your 
settings each time you run the application for a consistent look and feel.  However, at 
some point you may decide to restore the layout to the original settings.  Use these 
buttons to reset the layout of the windows or toolbars. 
 

Loading Patterns and Pads from other files 
Use the Tools menu to load existing patterns or pads from another song you’ve written.  
You will be prompted to find the file, and then a list of patterns or pads will be presented. 
The Load Patterns screen looks like this: 



 
 
The Load kit screen looks like this: 

 
 
In either screen, select the items to load by clicking the row selector on the left side.  You 
can hold CONTROL while you click to select more than one, or use SHIFT as you click 
to select a range of items.  If you want to load all the items, click the Select All button at 
the bottom of the form.  When you are ready, click OK. 



The lower section of the screen has options for handling matching sample pads.  Note 
that this is only used for pads that have the same name (this is not case-sensitive).  For 
example if you already have a pad called “Snare” in your song, then you elect to load a 
pad called “snare” from this screen, you have to decide if you want to keep both snares, 
or your original “Snare”, or the “snare” in the file you are looking at.   
 
You can elect to keep your current pads, replace them with the pads from the files you’re 
loading, or to load them all (allow duplicates).  When importing a “kit”, you’ll usually 
want to replace your current pads with the new ones.  When importing patterns, you’ll 
usually want to keep your current pads… But you can change this if needed. 
 
NOTE: The pad Name is used to do the comparison (case-insensitive). 
For example, if you are importing from another song which had a snare pad called 
“Snare”, but your current song has a snare called “GoodSnare”, then Rhythm Rascal will 
add “Snare” to your current song. (It is not able to correlate the two since they have 
different names) You now have “Snare” and “GoodSnare” in the song.  To avoid this 
issue, be sure to name your snare the same thing in both songs. 
 

Template Patterns 
Rhythm Rascal comes with a few “template patterns” to help save you time.  These are 
patterns based on common rock and metal progressions.  Use Edit->Pattern->New 
pattern from template to insert one of these templates into your song.  Once you have 
inserted the pattern, you can change it however you like. 
 
If you want to add your own template patterns or modify the standard ones, simply open 
the template files in Rhythm Rascal by using File->Open.  They will look like regular 
songs.  Create or modify patterns and save the file. 
 
Rhythm Rascal currently comes with two templates, Rock and Metal.  You can modify 
these templates, or you can create your own custom templates.  To create your own 
templates, create the patterns normally in Rhythm Rascal.  Then save the .rrp file to the 
“templates” folder under the main program folder (usually C:\Program Files\Rhythm 
Rascal\Rhythm Rascal\templates).  You can use any name you like for the file, as long as 
it ends with .rrp.  The next time you start Rhythm Rascal, your new templates will show 
up in the Edit->Pattern menu. 
 
NOTE: When adding new template files, you won’t see them in the menu until the next 
time you start the program.  If you simply change the existing ones, you do not need to 
restart. 
 
 



Import/Export 
The export feature lets you copy the current project, and all of its sample files to a zip 
archive file.  The purpose of this is that you can then take that zip file and move it 
between computers (i.e. you could email the zip file to a friend).   
 
This is especially handy if you are referencing sample files that are in different folders on 
your computer – the export will consolidate everything to a single folder within the zip 
archive. 
 
Rhythm Rascal uses a standard compression (or “zip”) process so your archives can be 
opened with any standard compression tool, such as WinZip (http://winzip.com/). 
 
Similarly, the import feature extracts the Rhythm Rascal data from an export file.  If you 
have received a zip file, you can use this feature to open it.  Alternatively, if you have a 
decompression tool such as WinZip, you can simply open the zip file and extract the 
contents using the decompression tool. 
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